Search found 5 matches

by AidoKsev
Wed Oct 09, 2013 2:04 am
Forum: TECH: 4A-GE ENGINE
Topic: 4AC Head on 20V S/T Block?!?!
Replies: 3
Views: 1018

4AC Head on 20V S/T Block?!?!

Hey guys, recently my car got defected (I'm in Australia) for having a 20 Valve motor in my KE70, and I cannot get it over the pits as it has too much powahhh, therefore it has to be certified by an engineer, which is a minimum of six to eight weeks before anyone can come and sign off on it. However...
by AidoKsev
Thu Apr 11, 2013 5:38 am
Forum: TECH: 4A-GE ENGINE
Topic: 16V Doing My Head In!!
Replies: 4
Views: 1240

Re: 16V Doing My Head In!!

Injectors ground through the ECU, like I've said it is completely re-wired so none of the standard earths are there. It has a magnificent Injector Pulse and sprays fuel when the rail is unbolted. I'll check Fuel pressure again soon but this seems to be the problem. Also what is the correct injector ...
by AidoKsev
Tue Apr 09, 2013 6:48 am
Forum: TECH: 4A-GE ENGINE
Topic: 16V Doing My Head In!!
Replies: 4
Views: 1240

16V Doing My Head In!!

G'day forum folk! The problem... I have just wired in a 16V Bigport into a friends KE70 from scratch [Standard ECU] (not the first nor last time I'm sure...) and I have come up with this problem of having no fuel delivered via the injectors upon trying to start/run. I remove the dizzy and spin it I ...
by AidoKsev
Thu Feb 14, 2013 3:36 am
Forum: TECH: 4A-GE ENGINE
Topic: Another Timing Issue...
Replies: 6
Views: 1525

Re: Another Timing Issue...

Yes we can set all the timing ourselves but the problem is it somehow mechanically retards, like I say, we lock the ECU at 20 degrees (therefore the ECU no longer controls timing) and theoretically it shouldn't move at all, but somehow it still retards... It is possible to tune around it and add our...
by AidoKsev
Wed Feb 13, 2013 3:58 am
Forum: TECH: 4A-GE ENGINE
Topic: Another Timing Issue...
Replies: 6
Views: 1525

Another Timing Issue...

Okay so this one is a bit different, or its just that I cant find anything on the same problem... The vehicle is an AE86, however regardless of this problem... It is powered by a 16 Valve Bigport with Cams, Cam Gears, ITB's, blah blah. Originally it was running the standard ECU and an SAFC for the t...

Go to advanced search