Hesitation at low rpms

User avatar
Jayrdee
Club4AG Expert
Posts: 288
Joined: Tue Mar 21, 2017 8:25 am
Location: Lexington KY
Contact:

Hesitation at low rpms

Postby Jayrdee » Wed Sep 05, 2018 6:13 am

For the past few months I've noticed my AE86 has a hesitation at low RPMS. It only occurs during initial acceleration, for example taking off in 1st gear from a stop light. I would press the accelerator and it would hesitate until about 3k and then take off. I tried looking up to see if it was a common thing but no one else seemed to have the same symptoms.

For the longest time it would only happen when the car is cold. I'd back the car out, press the accelerator, it would hesitate for a second, hit 3k and then take off. Once the car is rolling and warms up it would go away. I figured it was some kind of vacuum problem, maybe looses pressure or something whenever the car sits for a little while, so I would let the car warm up before driving and that seemed to work ... until last night.

I drove it a little hard and held it open at WOT for extended periods of time, and then the hesitations came back. This time its 1st and 2nd gear. Once it gets up to speed the hesitations go away but it feels like its only running at 75-80%.

Anyone else run into this problem before? Some feedback would be nice before I start throwing random punches at it.

Thanks fellas!

Image
Image
[I have no idea what I'm doing]
_____________________
instagram: @jacobdurbin

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
jondee86
Moderator
Posts: 2322
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: Hesitation at low rpms

Postby jondee86 » Wed Sep 05, 2018 6:13 pm

Could be fuel or timing. Since I'm guessing that you don't have a WBO2 gauge,
it's probably best to just check a few of the basics...
- Pull the plugs and check for colour/condition.
- Set the engine to TDC compression stroke on #1 cylinder by lining the crank
pulley notch with the timing cover zero mark. Pull the top timing belt cover and
see if the dimples on the cam pulleys line up with the marks on the backing plate.
- Check the timing belt condition/tension while you are in there.
- Check the ignition timing with a timing light. Should be around 16-17deg BTDC
with warm engine idling at around 900rpm (diagnostic plug NOT jumped).
- AAV working properly... cold start rpm should jump to around 2200rpm and then
taper down as the engine warms up.
- Check the intake air ducting between the AFM and the intake manifold for
leaks/splits. You may have to take the ducting off to check as if it splits in the
corrugated part it is hard to find the split unless you can hold the duct to the light.

If the plugs, timing and air intake are all good, then it may be running a little
lean while warming up and that means checking a few fuel related items. such as
pump, filter, ECU coolant sensor. That's a bit more work, so do the easy stuff
first and eliminate a lot of the possible causes before digging deeper.

BTW... nice angle on that second pic :)

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

davew7
Club4AG Enthusiast
Posts: 170
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: Hesitation at low rpms

Postby davew7 » Thu Sep 06, 2018 3:54 am

You need a richer mixture at throttle tip in. That 30+ year old fuel pump does not have enough pressure to enrich the mixture enough. Pull the fuel line at the filter and verify "deadhead" the line into a pressure gauge. You need a PSI reading in the mid 40's to get a regulated PSI in the 38-to-40 range. Could also be rust in the filter or the fuel pump intake sock.
DaveW

User avatar
Jayrdee
Club4AG Expert
Posts: 288
Joined: Tue Mar 21, 2017 8:25 am
Location: Lexington KY
Contact:

Re: Hesitation at low rpms

Postby Jayrdee » Thu Sep 06, 2018 10:01 am

Thanks for the replies! The plugs and timing belt are new, I replaced all that stuff this past winter and have put maybe 5k miles on the car since then. I verified it was all in time too before I put it all back together. My car is jdm so I don't have a AFM sensor either. The hesitations happened before I made the repairs, but not as frequently as now.

The ECU Coolant Sensor, thats on the back of the head, right? Goes in that little plate back by the firewall? I was thinking about possible causes and that could be it, I do have a coolant leak at the plate I need to fix.

I was thinking about the fuel filter / pump. I highly doubt those have been changed so 30 year old rusty stuff could be the cause, but wouldn't the hesitations be present throughout the entire rev range? Especially going up a hill? Mine only occurs at low RPMS, regardless of incline. Once its going, its fine.

Another idea, what about the TPS Sensor? its basically a potentiometer thing and sends the change in resistance to the ECU, right? If its not reading correctly when I press the throttle that could be the cause. And could also explain why the hesitations occurred after beating on the car too Lol. Bangin' gears, repeated on/off the throttle, etc. That could have an effect on the sensor if the wiper/resistive element is going bad.

I'll still look over everything you all mentioned anyways.
[I have no idea what I'm doing]
_____________________
instagram: @jacobdurbin

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
jondee86
Moderator
Posts: 2322
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: Hesitation at low rpms

Postby jondee86 » Thu Sep 06, 2018 9:27 pm

The ECU water temp sensor behind the head is the green one. The brown one is the
cold start injector time switch. The temp sensor is a thermistor, so basically pretty
reliable. The test is to check the resistance of the sensor and compare with the graph
in the service manual.

Kind of awkward to get at it though, so probably leave that one for later. If the car
started and drove OK from a cold start in winter, I'd hazard a guess that the sensor
is fine.

The TPS could be a suspect. The wiper on the carbon track spends the greater part
of its life jiggling around at low throttle openings. So it can become worn in the zone
that your hesitation occurs. You need to pull the plug and test the pins on the TPS
itself. This is one time that an analog multimeter is better, but a digital meter will
get there as well. You watch the reading while slowly and smoothly opening the throttle.

You are looking for the meter reading to slowly and smoothly change from a high to a
low value, or vice versa. If the reading has spikes or dropouts (jumps around) instead
of changing smoothly and continuously, then you need to find another TPS.

Fuel is a hard call... its a possible, but as you say, WOT at high rpm requires a lot
more fuel than just sedately accelerating away from a stop light. On the other hand,
beating on the car will stir up any sediment in the tank and possibly add a bit more
crud to an already partially clogged filter.

If the filter shows no signs of being changed since the car was built, whack a new one
in there and cut the old one open. If it packed with a brown paste then that will be
rust particles from the tank. In that case you should probably pull the tank and see how
the pump and in-tank filter are looking. But test the TPS first :)

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

davew7
Club4AG Enthusiast
Posts: 170
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: Hesitation at low rpms

Postby davew7 » Fri Sep 07, 2018 4:35 am

The TPS is a good possibility, but it would not explain the difference you see between a hot and cold engine. The cold engine needs more fuel, i.e. the green sensor, tells the ECU that more fuel is needed but the fuel pressure is not there to deliver it. DaveW7

User avatar
Jayrdee
Club4AG Expert
Posts: 288
Joined: Tue Mar 21, 2017 8:25 am
Location: Lexington KY
Contact:

Re: Hesitation at low rpms

Postby Jayrdee » Fri Sep 07, 2018 9:12 am

You guys are awesome.

Looks like I have a few more things to add to the "to-do" list. :lol:
[I have no idea what I'm doing]
_____________________
instagram: @jacobdurbin

UNLIMITED 86
Club4AG Enthusiast
Posts: 56
Joined: Mon Jan 14, 2013 10:38 pm
Location: 619

Re: Hesitation at low rpms

Postby UNLIMITED 86 » Sun Oct 07, 2018 7:40 am

Sounds like a fuel supply issue.

It's most likely an issue inside of the tank. I would not start at the fuel filter under the hood; more likely to be an issue with the strainer on the pump inlet.

Another thing to check is the short rubber fuel line on the outlet of your fuel pump.

If you're in the US, you might want to replace that hose regardless... why? A few years ago, they started mixing ethanol into our normal gasoline (huge ripoff to us consumers, btw but I digress). The original fuel line wasn't designed for the ethanol mixture, and, since it is exposed to fuel on both sides inside the tank, it's essentially "burning the candle at both ends."
Make Club4AG Great Again!

CloudStrife
Club4AG Pro
Posts: 630
Joined: Thu Oct 06, 2016 2:23 pm
Location: Middle of Hell, Florida

Re: Hesitation at low rpms

Postby CloudStrife » Wed Nov 07, 2018 11:50 am

I think 10% C2H5OH is kind of a loose point, but if you want you can look up "Top Tier" gas companies. They are non-ethanol make-up pump-gas options at stations like BP I believe, I personally don't like to run Ethanol based, but I don't think it'll kill yer baby :).

The best thing you can do, which nobody really wants to do, is drain the tank (it takes a 4 point socket), pull the tank, clean the hell out of it, and replace, refresh, and re-clean anything you can.

I would then prime the fuel pump (poor man mods has a video on this), so that the pump throws out all the old fuel, and maybe even some kind of solution to run through it.

then I'd replace the filter, pump, and anything else in line. That way you won't have anything gumming up your fresh screen!

After that I'd start studying TPS adjustment and all the things Dave and Jon said (and of course everything Unlimited suggested), then I'd look at getting timing right.

But I agree fuel supply issue..
Success guardian... Successsssssss..

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “TECH: Corolla AE86”

Who is online

Users browsing this forum: No registered users and 5 guests