Electrical Gremlins in the Blower Circuit?

5280_GTS
Club4AG Regular
Posts: 11
Joined: Sun Apr 02, 2017 3:20 pm
Location: The Mile High City

Electrical Gremlins in the Blower Circuit?

Postby 5280_GTS » Sat Nov 04, 2017 11:54 pm

Was on a drive the other day and on the way home, my gauges started going crazy.

The tach dropped to 300 rpm, the brake light came on in the dash, the oil pressure gauge is pinned past the H, the Temp Gauge wont go past 1/4 of the gauge and the Blower motor turned itself off. Once I got home I checked all the fuses and noticed that the 7.5A Gauge Fuse was blown so I replaced it and started the car. The tach seemed fixed, but it wont rev past 3000rpm, even though the engine will. The brake light on the dash stays on and wont go away but is very faint. The Blower doesnt turn on at any of the speeds and when switched on, kills the Head Lights.

I checked all the fuses and they were fine.
I checked the Connector at the Temp Sensor and its fine.
I checked the Head Light Relay, Heater Relay, Blower Breaker and Blower Motor and they were good too.
I checked the Wiring from the E-brake Switch to the Instrument Cluster and they were fine and I have plenty of Brake Fluid.
The Head Lights work fine by themselves, but if you move the blower switch to any speed, they turn off.

Been having a real hard time trying to figure this one out and have tried almost everything. It's like all the most difficult, pain in the ass, intermittent problems always seem to find me and at the worst times(perhaps that's just an 86 thing?). Winter is Coming here in the Rockies and I really need that blower working any help would be greatly appreciated.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


totta crolla
Club4AG Expert
Posts: 456
Joined: Tue Mar 26, 2013 5:21 am
Location: Oxford U.K

Re: Electrical Gremlins in the Blower Circuit?

Postby totta crolla » Sun Nov 05, 2017 12:52 am

There will be some trial and error fixing this problem. First check all of the grounding points and if they are ok you might be able to isolate the problem to a particular circuit by removing fuses. Remove a circuit fuse, create problem by switching on blower and if fault remains replace fuse and move on to another circuit. Sometimes a dying alternator can show similar symptoms but don't get too hung up on
that.


Return to “TECH: Corolla AE86”

Who is online

Users browsing this forum: No registered users and 10 guests