Oxygen Sensor help

dabes
Club4AG Regular
Posts: 22
Joined: Wed Aug 07, 2013 11:06 am

Oxygen Sensor help

Postby dabes » Sat Jun 10, 2017 11:34 am

Long story short i have had my 86 for a while, it is on the stock USDM engine and ecu. I just found out that the line to my oxygen sensor is cut. the car runs fine, and there is no check engine light. In fact its probably been this way throughout its life of me owning it (from daily commutes in the past to track events)

That being said I feel the need to fix this issue now that I found that its not connected.

The issue is that the line is cut and I have no connector or anything on the harness that lets me know which line is supposed to connect to the o2.

Can someone show me where the line should come from? I have 2 black wires close to the driver side motor mount. also a few unplugged connector on the passenger side wiper motors.

I will take a few pictures and post them shorty. but if anyone might be able to show me a picture of where the o2 sensor wire would come from in the harness that would be a lot of help.

Thank you

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


dabes
Club4AG Regular
Posts: 22
Joined: Wed Aug 07, 2013 11:06 am

Re: Oxygen Sensor help

Postby dabes » Mon Jun 12, 2017 12:12 pm

can anyone else me out?

shagymc
Club4AG Expert
Posts: 342
Joined: Mon Jan 14, 2013 9:43 pm

Re: Oxygen Sensor help

Postby shagymc » Mon Jun 12, 2017 12:53 pm

I'll get tech drawings offline when I get home tonight, but the best thing I would recommend is finding the pin in the ecu plug that comes from the O2 sensor, se your meter on continuity and test either of the two wires you suspect to be it. Ensure the plug is unplugged from the ecu when testing. I'd also check the ecu side of the wire to ground to make sure that it isn't grounded and giving erroneous readings on the meter. If that doesn't make sense PM me and I'll walk you through it.

User avatar
jondee86
Moderator
Posts: 2056
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: Oxygen Sensor help

Postby jondee86 » Mon Jun 12, 2017 2:43 pm

Maybe this helps ?
Image
http://www.club4ag.com/forums/viewtopic.php?f=9&t=4049

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “TECH: Corolla AE86”

Who is online

Users browsing this forum: No registered users and 4 guests