4AG Silver Top 20V Idling High

User avatar
BlueAngel
Club4AG Regular
Posts: 11
Joined: Fri Nov 08, 2013 10:38 am

4AG Silver Top 20V Idling High

Postby BlueAngel » Fri Apr 20, 2018 4:35 pm

New some advise please.
My Silvertop engine seems to be idling very high at all times (about 1400-1500 RPM's) cold or hot, it doesnt lower the RPM's unless I turn the AC on and will go down tio about 800-900. the throttle cable seems to be loose enough, and the leveler between the throttles with the screw for adjustment, is missing the screw. I added one, but the pin where the screw rest is pushing the throttle open increasing the RPM's. I cannot find any ways to reposition the leveler or to lower the RPM's.
Has anybody using this engine, come across this or similar issue?

please advise
Thank you

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
jondee86
Moderator
Posts: 2241
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: 4AG Silver Top 20V Idling High

Postby jondee86 » Fri Apr 20, 2018 11:33 pm

If you are talking about this thing...

Image

... the "throttle opener", then you need to adjust the screw while the engine is running.
When the engine starts and vacuum is available to the actuator, the pin retracts a few
millimeters. So with the engine running, adjust the screw so that the pin is no longer
pushing on the throttle spindle arm.

Factory spec says disconnect the vacuum hose from the throttle opener (block the end
of the hose) so that the pin extends and opens the throttles. The idle speed for a fully
warmedengine should be 2500 rpm or less. Adjust the screw if necessary.

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

User avatar
BlueAngel
Club4AG Regular
Posts: 11
Joined: Fri Nov 08, 2013 10:38 am

Re: 4AG Silver Top 20V Idling High

Postby BlueAngel » Sun Apr 22, 2018 1:53 pm

Thank you Jondee86
I'll try that!!

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “TECH: 4A-GE ENGINE”

Who is online

Users browsing this forum: No registered users and 3 guests