Check engine light at high RPM

kevinmetal
Posts: 5
Joined: Fri Jan 11, 2013 10:30 pm

Check engine light at high RPM

Postby kevinmetal » Wed Apr 05, 2017 5:04 pm

I have a 85 GT-S with stock 16v and I'm getting a code 4- water temp sensor at about 5-6k and it will stay on while driving until I come to a stop and then the light will go away. Car will still run fine with no issues. I see 3 sensors together on the thermostat housing, I know the middle one is for the gauge, but I'm not sure which of the other 2 are for the ecu?

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
jondee86
Moderator
Posts: 2001
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: Check engine light at high RPM

Postby jondee86 » Tue Apr 11, 2017 10:14 pm

There are two sensors besides the gauge sensor. The green one is the ECU water temp sensor.
The brown one is the cold start injector time switch. The time switch does not have anything
to do with the ECU. It just gets power during cranking, and if the engine is cool enough it will
activate the cold start injector.

So check the plug is tight and sitting properly on the green sensor, and check the wires for any
signs of corrosion or internal breakage due to the wires flexing for 30 years :)

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.


Return to “TECH: 4A-GE ENGINE”

Who is online

Users browsing this forum: No registered users and 7 guests