High Oil Pressure AE86

Swooki
Club4AG Regular
Posts: 47
Joined: Wed Dec 21, 2016 1:48 pm

High Oil Pressure AE86

Postby Swooki » Mon Mar 13, 2017 7:28 pm

Hey so i was driving today and everything was cool until i noticed that the Oil Pressure went to High. I noticed it when i was at the night waiting to turn left. When the light turned green i went to a parking lot and parked and before i got to the parking lot like at the entrance (dip) of the parking lot it was to Low again. This is how low it'll get and when i start driving this is how high it went. Why did this happen?

Pictures below shows how it looked. the (red) line i drew indicates the gauge needle.

This is how low it was when it dropped and also when i idle sometimes.
Image


This is how it is when i start the car it immediately goes here usually.
Image


This is what i meant by high. Should i be worried? :( :shock: :?:
Image

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


davew7
Club4AG Enthusiast
Posts: 103
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: High Oil Pressure AE86

Postby davew7 » Tue Mar 14, 2017 6:07 am

My first guess is an electrical issue.
Your oil pressure sensor is located right under your distributor. Clean and tighten the electrical connection.
Odds are a lot lower that it is a pressure relief valve. Dave W

Swooki
Club4AG Regular
Posts: 47
Joined: Wed Dec 21, 2016 1:48 pm

Re: High Oil Pressure AE86

Postby Swooki » Wed Apr 05, 2017 12:19 am

davew7 wrote:My first guess is an electrical issue.
Your oil pressure sensor is located right under your distributor. Clean and tighten the electrical connection.
Odds are a lot lower that it is a pressure relief valve. Dave W


Sometimes still happens.

davew7
Club4AG Enthusiast
Posts: 103
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: High Oil Pressure AE86

Postby davew7 » Wed Apr 05, 2017 5:26 am

I would still bet that you have an electrical issue. You will have to trace the wiring and the plug connectors and look for a short or loose/bad connections, which will be a real PITA. If it was me, I would just run a new wire(s). I've spent hours tracking down a single bad connection pin that you could not see any corrosion on. If it would make you feel better you can remove the lower plug on the oil filter adaptor and clean the pressure by-pass valve just to be safe. But if you had real low pressure you would probably hear the engine rattling. Dave W

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
SR85DET
Club4AG Enthusiast
Posts: 131
Joined: Sat Feb 16, 2013 7:16 am

Re: High Oil Pressure AE86

Postby SR85DET » Wed Apr 05, 2017 6:50 am

A lot of times the wiring itself is not so great underneath the insulation. I agree with it being an electrical issue and could be the instrument cluster. I am having the same issue with my temperature gauge. After all, the reading is based off resistance. Corrosion (creating high resistance) will throw off the reading. This could be the sensor, wiring (most likely) or cluster (possible, especially if not driven much and sitting outside).

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “TECH: 4A-GE ENGINE”

Who is online

Users browsing this forum: No registered users and 2 guests