4age smallport no throttle response

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

4age smallport no throttle response

Postby alooo » Mon Dec 21, 2015 12:38 pm

hey guys , just dne a smallport swap on my ae92 ,but facing a problem the engine starts well but dosent respond on WOT (what i mean to say is when i start the engine it stars fine but when i try to increase the RPM the engine doesnt respond the engine doesn't go above 1000-1500 RPM) the map sensor is connected, TPS is also connected fuel pressure is fine the ignition timing is also fine , on WOT it backfires some times , no idea what is wrong
please help!!! :oops: :oops:

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


yoshimitsuspeed
Club4AG MASTER
Posts: 2084
Joined: Sun Jan 13, 2013 1:18 pm
Contact:

Re: 4age smallport no throttle response

Postby yoshimitsuspeed » Mon Dec 21, 2015 1:18 pm

What have you done to diagnose? What have you tested?
Have you gone through all the diagnostics and troubleshooting in the FSM?
For example have you tested and adjusted the TPS?
Have you set timing with a timing light?
What else have you done?

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Tue Dec 22, 2015 3:02 am

have tested the TPS it works fine , the timing has not been touched as it was fine when i bought the engine ,
have no idea what to do or check ..
if you can guide me on some specific parts to check on ,i would really appreciate it as i am new to this life style of engine swaps

yoshimitsuspeed
Club4AG MASTER
Posts: 2084
Joined: Sun Jan 13, 2013 1:18 pm
Contact:

Re: 4age smallport no throttle response

Postby yoshimitsuspeed » Tue Dec 22, 2015 3:18 am

alooo wrote:have tested the TPS it works fine


Your phrasing doesn't inspire confidence.
You checked it by the book using a multimeter?
http://www.matrixgarage.com/content/4age-tps-adjustment

alooo wrote: the timing has not been touched as it was fine when i bought the engine ,
have no idea what to do or check ..
if you can guide me on some specific parts to check on ,i would really appreciate it as i am new to this life style of engine swaps

Apparently so
Always check the timing. If you weren't the last one to do it, check the timing, if you don't know or remember when it was done last check the timing, if something gets funny check the timing, if you are bored check the timing.

Do you have an FSM? 90% of everything you need to know is in there and for us to cover it all we would literally have to write a book. A rather large one at that.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Tue Dec 22, 2015 7:58 am

what do u mean by FSM ?
my machanic has checked the TPS and he says that its working as it should
checked the timing again its perfect both the cams and ignition
my machanic told me its due to the igniter i am using (i am using a lexus ls400 igniter) but i doubt that what has the igniter got to do with it (i may be wrong )

yoshimitsuspeed
Club4AG MASTER
Posts: 2084
Joined: Sun Jan 13, 2013 1:18 pm
Contact:

Re: 4age smallport no throttle response

Postby yoshimitsuspeed » Tue Dec 22, 2015 10:16 am

Your last post suggests that you don't do any of your own work on the car.
The comment about your mechanic testing your TPS suggests that you trust your mechanic.
If you don't generally work on your own cars and if you have a trusted mechanic then why are you trying to do their job for them?
The FSM is the factory service manual. Not only should you have one before even starting a swap but you should know not only that acronym but most contained therein before even considering a swap. Unless you are going to pay someone else to do everything. And then you must be okay with relying on them from then on to take care of any little issue that arises.

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Tue Dec 22, 2015 11:55 am

where i come from people dont themselves do the swap or tune their own car here every enthusiast takes his car to the garage for swaps and all
i just wanted some help because my mechanic seems to be confused too on the error redtop 4age was actually the best option for me at the moment my future plans are going gte on a long block
here in dubai we dont swap engines ourselves here we do thngs the different way
would like to tell u that i am the first one in the whole country to swap a redtop 4age in my ae92
people have done silver top and black top swaps but non have done the 4age red top
not a lot of people own ae86 (hachiroku) here just some lucky ones (2-3 owners) and they run 3sgte under their hood
that the reason not a lot of machanics are familiar with the 4age smallport electrics
all the ae92 imported here in the middle east were either 2e or 4a carb..
no ae92 with 4age here

yoshimitsuspeed
Club4AG MASTER
Posts: 2084
Joined: Sun Jan 13, 2013 1:18 pm
Contact:

Re: 4age smallport no throttle response

Postby yoshimitsuspeed » Tue Dec 22, 2015 12:31 pm

Well in that case my rates are 2 tickets to Dubai, room and board and $100 USD/hr.

User avatar
oldeskewltoy
Club4AG MASTER
Posts: 1781
Joined: Wed Jan 09, 2013 4:44 pm
Location: Portland, Oregon

Re: 4age smallport no throttle response

Postby oldeskewltoy » Tue Dec 22, 2015 12:56 pm

alooo wrote:where i come from people dont themselves do the swap or tune their own car here every enthusiast takes his car to the garage for swaps and all
i just wanted some help because my mechanic seems to be confused too on the error redtop 4age was actually the best option for me at the moment my future plans are going gte on a long block
here in dubai we dont swap engines ourselves here we do thngs the different way
would like to tell u that i am the first one in the whole country to swap a redtop 4age in my ae92
people have done silver top and black top swaps but non have done the 4age red top
not a lot of people own ae86 (hachiroku) here just some lucky ones (2-3 owners) and they run 3sgte under their hood
that the reason not a lot of machanics are familiar with the 4age smallport electrics
all the ae92 imported here in the middle east were either 2e or 4a carb..
no ae92 with 4age here



When your mechanic swapped the 4AGE, did he get the 4AGE wiring swapped too?

If he swapped the wiring, was it the wiring from the smallport 4AGE?

Can you afford to have a complete aftermarket engine management system installed?
OST Cyl head porting, - viewtopic.php?f=22&t=300

Building a great engine takes knowing the end... before you begin :ugeek:

Enjoy Life... its the only one you get!

totta crolla
Club4AG Expert
Posts: 493
Joined: Tue Mar 26, 2013 5:21 am
Location: Oxford U.K

Re: 4age smallport no throttle response

Postby totta crolla » Tue Dec 22, 2015 2:47 pm


alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Thu Dec 24, 2015 8:46 am

oldeskewltoy wrote:
alooo wrote:where i come from people dont themselves do the swap or tune their own car here every enthusiast takes his car to the garage for swaps and all
i just wanted some help because my mechanic seems to be confused too on the error redtop 4age was actually the best option for me at the moment my future plans are going gte on a long block
here in dubai we dont swap engines ourselves here we do thngs the different way
would like to tell u that i am the first one in the whole country to swap a redtop 4age in my ae92
people have done silver top and black top swaps but non have done the 4age red top
not a lot of people own ae86 (hachiroku) here just some lucky ones (2-3 owners) and they run 3sgte under their hood
that the reason not a lot of machanics are familiar with the 4age smallport electrics
all the ae92 imported here in the middle east were either 2e or 4a carb..
no ae92 with 4age here



When your mechanic swapped the 4AGE, did he get the 4AGE wiring swapped too?

If he swapped the wiring, was it the wiring from the smallport 4AGE?

Can you afford to have a complete aftermarket engine management system installed?



yes he did the wiring as well
it was the wiring from smallport
at the moment i cant afford an aftermarket ecu will have to stick with the factory one
is it possible my factory ecu is corrupted?

totta crolla
Club4AG Expert
Posts: 493
Joined: Tue Mar 26, 2013 5:21 am
Location: Oxford U.K

Re: 4age smallport no throttle response

Postby totta crolla » Thu Dec 24, 2015 10:07 am

alooo wrote:
oldeskewltoy wrote:
alooo wrote:where i come from people dont themselves do the swap or tune their own car here every enthusiast takes his car to the garage for swaps and all
i just wanted some help because my mechanic seems to be confused too on the error redtop 4age was actually the best option for me at the moment my future plans are going gte on a long block
here in dubai we dont swap engines ourselves here we do thngs the different way
would like to tell u that i am the first one in the whole country to swap a redtop 4age in my ae92
people have done silver top and black top swaps but non have done the 4age red top
not a lot of people own ae86 (hachiroku) here just some lucky ones (2-3 owners) and they run 3sgte under their hood
that the reason not a lot of machanics are familiar with the 4age smallport electrics
all the ae92 imported here in the middle east were either 2e or 4a carb..
no ae92 with 4age here



When your mechanic swapped the 4AGE, did he get the 4AGE wiring swapped too?

If he swapped the wiring, was it the wiring from the smallport 4AGE?

Can you afford to have a complete aftermarket engine management system installed?



yes he did the wiring as well
it was the wiring from smallport
at the moment i cant afford an aftermarket ecu will have to stick with the factory one
is it possible my factory ecu is corrupted?


JUST DO THE EFFING TEST :evil:

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Thu Dec 24, 2015 10:16 am

done every think i could do but nutin positive
guess no one can help me on this one ...

totta crolla
Club4AG Expert
Posts: 493
Joined: Tue Mar 26, 2013 5:21 am
Location: Oxford U.K

Re: 4age smallport no throttle response

Postby totta crolla » Thu Dec 24, 2015 1:45 pm

No one so deaf as those that refuse to listen.

User avatar
jondee86
Moderator
Posts: 2296
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: 4age smallport no throttle response

Postby jondee86 » Thu Dec 24, 2015 3:19 pm

alooo wrote:My machanic told me its due to the igniter i am using (i am using a lexus ls400 igniter)

It is possible that your mechanic is onto something :) Although I have not
been able to find anything to definitely confirm one way or the other, there
is a good chance that the LS400 igniter is a "smart igniter" with dwell control
built-in. Your AE92 ECU was built to use a "dumb igniter" and the dwell control
is done from within the ECU.

Anecdotal evidence says that a smart igniter and an ECU that controls dwell
do not play well together. The simple test seems to be that you check the
temperature of the igniter after the engine has been running for a while. If
it gets quite hot quite quickly, then you have the wrong igniter.

Best to see if you can find a dumb igniter from an 80's model toyota. Most
80's Toyotas and all 16V 4AGE's used dumb igniters. I can't guarantee that
this will cure the problem, but looking for an igniter will give you something
to do during the holiday period :-P

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Sat Dec 26, 2015 10:36 am

did not check that will check it first thing in the morning
my engine gets quite hot though after runung for a while (3/4 min) i thought it might be due to the headers i am using (not sure )

User avatar
jondee86
Moderator
Posts: 2296
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: 4age smallport no throttle response

Postby jondee86 » Sat Dec 26, 2015 6:00 pm

Happens that I was in my garage just now with my car idling for about
10-15 minutes while I messed with timing and idle speed. This is an AE92
smallport (non-TVIS) engine with stock igniter mounted quite close to the
exhaust manifold.

I checked the temperature of the igniter with my hand and it was quite
warm, but not so warm that you couldn'e hold your hand on it for a while.
Going out for a drive now, so I will check it again when I get home.

EDIT: After 20 minutes driving it is warmer... you can still put your hand
on the case, but only for a couple of seconds. I'd say its around 50 deg C.

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Sun Dec 27, 2015 1:10 pm

today while checking the map sensor i unplugged the map sensor with the vacuum hose on the engine revs till 3000-3500 rpm without the map connected, but when i plugged in the map the engine would refuse to rev tried 3/4 map sensors all the same, think i have not done the map wiring ryt
any one here could guide me on the map sensor wiring (my mapsensor wiring were cut from the engine when i bought it) a diagram or a pic showing he wires would be of much help ...

totta crolla
Club4AG Expert
Posts: 493
Joined: Tue Mar 26, 2013 5:21 am
Location: Oxford U.K

Re: 4age smallport no throttle response

Postby totta crolla » Sun Dec 27, 2015 1:54 pm


User avatar
jondee86
Moderator
Posts: 2296
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: 4age smallport no throttle response

Postby jondee86 » Sun Dec 27, 2015 3:24 pm

This diagram shows how the voltage of the MAP sensore changes...

Image

At idle (lots of vacuum) the output signal voltage is low, and at WOT
(no vacuum) the signal voltage is high. It may be possible to get the
wires reversed in some way, so that the signal varies in the wrong
direction. In which case the MAP sensor (which is the primary load
input for the ECU) will tell the ECU to supply a lot of fuel as soon as
the throttle opens a little bit, and reduce the fuel as the throttle opens.

In which case I would expect the engine to run very rich at 1500rpm
(stink of gas from the exhaust) and you would get black, soot deposits
on your spark plugs.

Does this happen ?

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

alooo
Club4AG Regular
Posts: 10
Joined: Mon Dec 21, 2015 12:25 pm

Re: 4age smallport no throttle response

Postby alooo » Mon Dec 28, 2015 10:02 am

that's exactly what happens (excessive black smoke and dark spark plugs)

User avatar
jondee86
Moderator
Posts: 2296
Joined: Fri Jan 11, 2013 10:21 pm
Location: Wellington, New Zealand

Re: 4age smallport no throttle response

Postby jondee86 » Mon Dec 28, 2015 2:07 pm

Here is a pic of an AE92 MAP sensor installed in an AE86 :)

Image

You will see the three colourws wires that go into the back of the plug. From
left to right looking into the back of the plug...

Yellow = Constant 5V power supply from the ECU
Light Green with Red stripe + Variable PIM signal back to the ECU
Brown + ECU ground

First confirm that you have the 5V supply on the lefthand pin. If you have, then
the other two wires must have got reversed somewhere. If you change them over,
it should work :)

Cheers... jondee86
Give a person a fish, they eat for a day. Suggest they search before posting, and they learn a skill for a lifetime.

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “TECH: 4A-GE ENGINE”

Who is online

Users browsing this forum: No registered users and 2 guests