4AG Won't Run/Dies Immediately

zokustyle
Club4AG Regular
Posts: 39
Joined: Sat Feb 23, 2013 3:18 pm

4AG Won't Run/Dies Immediately

Postby zokustyle » Sun Oct 25, 2015 2:08 am

'85 GTS: Cranks, fires for a second, then dies. Doesn't respond to throttle or unplugging things. Previous owner went over all the usuals: changed fuel pump, fuel filter, pulled COR and jumped fuel pump with a switch, replaced AFM. PO thought it was maybe FPR? Strange thing to me is that there's no CEL activity. As in, no light at all. bad ECU? AFM circuit? Igniter?

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


davew7
Club4AG Enthusiast
Posts: 170
Joined: Fri Jun 06, 2014 4:34 am
Location: Michigan

Re: 4AG Won't Run/Dies Immediately

Postby davew7 » Sun Oct 25, 2015 5:34 am

If it runs for a second then the fuel and igintion systems are probably good. If your ECU does not see any signal from the AFM at start up it will shut down the engine. Check the AFM connection and wires. Manually move the flap and verify a resistance change. Davew7

sirdeuce
Club4AG Pro
Posts: 589
Joined: Mon Jan 14, 2013 9:47 pm
Location: Sierra Nevada foothills

Re: 4AG Won't Run/Dies Immediately

Postby sirdeuce » Sun Oct 25, 2015 10:30 am

Go to your diagnostic port and try jumping the fuel pump. I'd look into the fuel pump relay and the switch in the AFM.
One shot, one kill.

jinx
Club4AG Expert
Posts: 243
Joined: Fri Jan 11, 2013 10:20 pm

Re: 4AG Won't Run/Dies Immediately

Postby jinx » Mon Oct 26, 2015 9:34 pm

any big vacuum leak would cause the exact same behaviour

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
jhtoy85
Posts: 7
Joined: Tue Aug 12, 2014 2:07 pm
Location: TEXAS

Re: 4AG Won't Run/Dies Immediately

Postby jhtoy85 » Wed Oct 28, 2015 6:40 pm

jinx wrote:any big vacuum leak would cause the exact same behaviour


If everything else is good. I agree with jinx. Check your air duct from the AFM to the throttle body. cracked, broken, or maybe not even clamped correctly, who's knows. Worth a shot.
BRRROOOOOM BRRRRRROOOOOOOOMM! "4AGE ENGINE"

allencr
Club4AG Expert
Posts: 359
Joined: Thu Jan 10, 2013 9:59 pm

Re: 4AG Won't Run/Dies Immediately

Postby allencr » Wed Oct 28, 2015 8:03 pm

What was done to it since it was last running, immediately before the first time it didn't start?
Very similar symptom to the very usual problem of those unconnected grounds under the intake.

zokustyle
Club4AG Regular
Posts: 39
Joined: Sat Feb 23, 2013 3:18 pm

Re: 4AG Won't Run/Dies Immediately

Postby zokustyle » Wed Oct 28, 2015 10:59 pm

That's a very good question, I bought the car with these symptoms...

A further inspection shows that all fuses are good, grounds are intact, but the original COR was in the glovebox so I suspected the COR was jumped or something. I checked and there's a new aftermarket relay in place of the COR that doesn't look great. Like a few have mentioned, I'm leaning toward this being a grounding or connection issue, since even the 4AG diagnostic manual says there's an issue with +B flow if the ECU doesn't illuminate the CEL with the key on. My biggest problem is that lately I haven't had any time to really get into this thing, just a few minutes here and there to poke at different things.

User avatar
saiGone
Club4AG Expert
Posts: 352
Joined: Tue Apr 08, 2014 1:42 pm

Re: 4AG Won't Run/Dies Immediately

Postby saiGone » Tue Nov 03, 2015 9:17 am

Check for the grounding on your injector resistor box. Or the box itself. Sounds like your running off of you cold start only.

Check all grounds in the injector cuircuit. 4 brown wires that ground on the intake mani. + the others
Club 4AG member since 05 (Formally SaigonsSon)

Image

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “TECH: 4A-GE ENGINE”

Who is online

Users browsing this forum: Bing [Bot] and 5 guests