Search found 5 matches

by kevinmetal
Wed Apr 05, 2017 5:04 pm
Forum: TECH: 4A-GE ENGINE
Topic: Check engine light at high RPM
Replies: 1
Views: 881

Check engine light at high RPM

I have a 85 GT-S with stock 16v and I'm getting a code 4- water temp sensor at about 5-6k and it will stay on while driving until I come to a stop and then the light will go away. Car will still run fine with no issues. I see 3 sensors together on the thermostat housing, I know the middle one is for...
by kevinmetal
Mon Mar 13, 2017 1:15 pm
Forum: TECH: 4A-GE ENGINE
Topic: 4ag 16v dies after warm up
Replies: 1
Views: 574

4ag 16v dies after warm up

So i have an 85 gts with the stock 16v, engine starts up fine with no issues, will run and idle fine for about 30 minutes, but after that it starts to die on me. if i give it throttle it will stay running and sometimes will stabilize for about another 5-10 minutes before it wants to die again. it ra...
by kevinmetal
Mon Aug 05, 2013 10:42 pm
Forum: TECH: Corolla AE86
Topic: aftermarket header issue
Replies: 8
Views: 1231

Re: aftermarket header issue

finally figured it out, the threads in the header were pretty bad so after using a tap and die set it went right in!
by kevinmetal
Mon Aug 05, 2013 9:37 am
Forum: TECH: Corolla AE86
Topic: aftermarket header issue
Replies: 8
Views: 1231

Re: aftermarket header issue

i probably should of mentioned that its just not threading in all the way
by kevinmetal
Mon Aug 05, 2013 9:20 am
Forum: TECH: Corolla AE86
Topic: aftermarket header issue
Replies: 8
Views: 1231

aftermarket header issue

hey guys im trying to install an aftermarket header on the my 16v but im having trouble getting the big bolt that goes on top of the header to go in, any solutions? trying to get this http://i10.photobucket.com/albums/a106/monkeypunk101/7760D9BC-5708-4885-A3B5-3AF6A38C1159-15751-00000D2F4E32AFFC.jpg...

Go to advanced search